Personal tools

GL-Inet

From Frack - Hackerspace Friesland

Jump to: navigation, search
Onderwerp: GL-Inet
Deskundigen
Afbeelding Anoniem.png FooBar
FooBar Rol: Deskundig met: GL-Inet Werkt aan: Geen projecten :(
,
Afbeelding Anoniem.png Fludizz
Fludizz Rol: deelnemer Deskundig met: GL-Inet, Glasvezel lassen, Iptables, Linux, Netwerken, OpenVPN, Python, RaspberryPi, Software Beginnend met: ENC28J60 Werkt aan: Fix de Mixer, Frack Kassa, FrackBot, Spacestate Switch v2, Spacestats
,
Gebruiker CrazyA.jpg CrazyA
Gebruiker CrazyA.jpgCrazyA Rol: deelnemer Deskundig met: AVR, Arduino, Blender, Elektronica, GL-Inet, LPD8806, POV-Ray, RaspberryPi Werkt aan: AVR kamerthermostaat

Kleine fijne routertjes met OpenWRT

De GL-Inet 802.11n wifi router draait op OpenWRT, gecompiled in China. Het doosje heeft twee bekabelde aansluitingen en een 2.4 GHz wifi-radio aan boord.

Meer informatie is te vinden bij: glinet.sigio.nl OpenWRT wiki RevSpace wiki

Flashen OpenWRT

Stable release

Bij het installeren van de Stable release van OpenWRT is het raadzaam om het "Keep settings" vinkje uit te zetten. Indien dit niet gedaan word is het mogelijk dat de webinterface het niet meer doet na het flashen.

Devel image

Bij het flashen van de trunk-versie van OpenWRT is de LuCi Web interface standaard niet geïnstalleerd. Zorg eerst dat je via telnet een wachtwoord hebt ingesteld zodat de rest van de installatie via ssh gedaan kan worden. Standaard is het ip 192.168.1.1 na installatie en staat telnet open zonder wachtwoord. Zodra met passwd een wachtwoord is ingesteld zal ssh automatisch aangezet worden. Zorg dat er een internetverbinding beschikbaar is. Gebruik opkg update om de package list te updaten en installeer daarna de boel met opkg install uhttpd luci luci-theme-openwrt

Bovenkant
Onderkant

Config om een GL-inet als ap only te gebruiken

#cat /etc/config/network 
 
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
 
config globals 'globals'
	option ula_prefix 'fd43:6287:76ad::/48'
 
config interface 'lan'
	option ifname 'eth0 eth1'
	option force_link '1'
	option type 'bridge'
	option proto 'dhcp'
#cat /etc/config/wireless 
 
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ar933x_wmac'
	option htmode 'HT20'
	option channel 'auto'
	option txpower '29'
	option country 'NL'
	option distance '10'
 
config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'my_ssid'
	option encryption 'psk2'
	option key 'my_password'
	option network 'lan'